[tex-live] .bat files and emacs [slightly off topic]

Siep Kroonenberg siepo at cybercomm.nl
Thu Nov 29 14:31:15 CET 2012

On Thu, Nov 29, 2012 at 12:41:05PM +0000, Lars Madsen wrote:
> hmm, that is not entirely true all the time.
> II can get it to work by opening a command prompt, but not if I double click it 
> (the script contains a 'pause' so if working it should not automatically close, which it does ...)
> /Lars Madsen
> Institut for Matematik / Department of Mathematics
> Aarhus Universitet / Aarhus University
> Mere info: http://au.dk/daleif@imf / More information: http://au.dk/en/daleif@imf
> ________________________________________
> From: tex-live [tex-live-bounces at tug.org] on behalf of Lars Madsen [daleif at imf.au.dk]
> Sent: 29 November 2012 13:32
> To: tex-live at tug.org
> Subject: [tex-live] .bat files and emacs [slightly off topic]
> Good news my transplantation script seems to be working
> Bad news: everytime I transfer it from my Ubunto to a windows VM apparently the line endings fail, and the .bat wrapper starts complaining.
> I've been messing with emacs on windows to force the encoding and line ending upon the files, but haven;t gotten the right compo yet
> Which encoding and options to zip are you guys using when preparing, say install-tl.zip?
> Nay ideas?

I just checked: many or most of my batchfiles appear to have Unix
line endings, but Windows does not complain about it. In my own
experience, notepad is the only remaining windows program that still
does not understand unix line endings.

As to how I transfer files: I keep my files on Linux and configure
my vms as samba clients. The vm's shared folders feature would
probably work just as well.

Siep Kroonenberg

More information about the tex-live mailing list