[tex-live] pdfcsplain.fmt not generated for all engines

Zdenek Wagner zdenek.wagner at gmail.com
Wed May 29 14:16:12 CEST 2013

2013/5/29 Petr Olsak <petr at olsak.net>:
> On Wed, 29 May 2013, Akira Kakuto wrote:
>> Hi Zdenek,
>>>  the pdfcsplain format is not generated for all engines as default, the
>>>  lines are commented out in fmtutil.cnf. After fresh install it
>>>  contains:
>>>  # from csplain:
>>>  csplain pdftex - -etex -enc csplain-utf8.ini
>>>  pdfcsplain pdftex - -etex -enc csplain-utf8.ini
>>> #!  pdfcsplain xetex - -etex csplain.ini
>>> #!  pdfcsplain luatex - -etex csplain.ini
>> Do you execute the other two like
>> xetex -fmt=pdfcsplain -progname=pdfcsplain foo
>> luatex -fmt=pdfcsplain -progname=pdfcsplain foo
>> because pdfcsplain is a symlink to pdftex?
>> At any rate, I think the present status is better
>> as a default.
>> Best regards,
>> Akira KAKUTO
> At December 2012 I was tested csplain in TeXlive and all formats of csplain
> were generated. Thus I wrote OK to Karl Berry (by email) and I supposed that
> this is definitive state. This state is documented in my documentation. Now,
> an user reprots that may documentation is not true. I was surprised that
> somebody changed this state, somebody who is not csplain user and without
> talking to me.
They were not created on my computers most probably because of my
fmtutil-local.cnf. Now I have removed pdfcsplain lines from my
fmtutil-local.cnf, updated TL2013pretest and now I see exactly the
same as other users after fresh install. I do not want to experiment
with TL2012 now because I am in a middle of an important job.

> Best Regards
> Petr Olsak

Zdeněk Wagner

More information about the tex-live mailing list